MySQL- 4.1 - не работает с Лазарем

Вопросы программирования и использования среды Lazarus.

Модератор: Модераторы

Сообщение SovNarKom » 13.08.2005 15:06:44

Занимаясь написанием cgi решил юзать mySQL.
Версия 3.23 работает нормально, я прямо счастлив...
Решил поставить версию поновее, и обнаружил, что Пакет 4.0 не работает ни с
версией MySQL-4.0 /Generally Available (GA) release ни
MySQL-4.1 /Generally Available (GA) release (recommended)!
При старте Лазаруса говорит, что не может найти процедуру mysql_server_init.

Качал с: <a href='http://www.mysql.ru/download/' target='_blank'>http://www.mysql.ru/download/</a>

Ваши мнения? :blink:
SovNarKom
постоялец
 
Сообщения: 389
Зарегистрирован: 28.05.2005 10:37:39
Откуда: Воронеж [vrn] [36]

Сообщение pda » 13.08.2005 16:48:45

Видать со старой либой собран. Попробуй установи compat пакет, м/б поможет...
Аватара пользователя
pda
постоялец
 
Сообщения: 303
Зарегистрирован: 27.05.2005 19:59:53

Сообщение Сергей Смирнов » 13.08.2005 22:13:34

Ё-моё, совсем народ обленился :) <a href='http://freepascal.ru/forum/index.php?showtopic=60' target='_blank'>тынц</a>
Аватара пользователя
Сергей Смирнов
энтузиаст
 
Сообщения: 595
Зарегистрирован: 28.04.2005 13:23:25
Откуда: Москва

Сообщение SovNarKom » 14.08.2005 00:10:00

Эн-нет... читал.
Другая фигня... у меня он точку входа находит...

не находит процедуру
mysql_connect(Если установлен пакет для 4 а dll-ка - 3.0)

не находит процедуру
mysql_server_init(Если установлен пакет для 4 и dll-ка - 4.0)


MySQL-4.0 /Generally Available (GA) release

Я уже и пересобирал... и dll-ки клал в корень...
что-то тут - не так... посмотрю ZEOS...
Оо.. нет великовато.... у меня консольное cgi без LCL, да ещё ZEOS под Delphi...

Проблема в том, что на большинстве серверов сейчас стоит 4... :(
SovNarKom
постоялец
 
Сообщения: 389
Зарегистрирован: 28.05.2005 10:37:39
Откуда: Воронеж [vrn] [36]

Сообщение SovNarKom » 14.08.2005 00:36:03

ВНИМАНИЕ!
Поставил компонент components\sqldb\mysql\mysql4connlaz.lpk - он - работает!
Вроде всё нормально. Как такое может быть?

-------------------------------------------------------

Ага {$Define LinkDynamically}
Используются mysql4dyn,mysql4_comdyn - вот где собака порылась :)
Буду мучать дальше...
SovNarKom
постоялец
 
Сообщения: 389
Зарегистрирован: 28.05.2005 10:37:39
Откуда: Воронеж [vrn] [36]


Вернуться в Lazarus

Кто сейчас на конференции

Сейчас этот форум просматривают: MSN [Bot] и гости: 7

Рейтинг@Mail.ru