После установки Лазаря на первом запуске "несовместимый ppu"

Общие вопросы программирования, алгоритмы и т.п.

Модератор: Модераторы

После установки Лазаря на первом запуске "несовместимый ppu"

Сообщение RustemNur » 19.02.2015 22:24:17

Скачал deb-пакеты с lazarus 1.4 RC1
Установил в ubuntu 14.04
Во время установки был предупрежден, что пакет lazarus не установился, т.к. остались неразрешенные зависимости (fpc установились без вопросов).
Чтобы долго не париться, установил lazarus 1.0.1, который есть в официальных репах, затем без проблем поставился лазарь 1.4
При компиляции и сборке пустого проекта - всё без замечаний. При попытке запуска из среды получаю ошибку:
unit1.pas(8,22) Error: Невозможно найти FileUtil, используемый в Unit1, несовместимый PPU=/usr/share/lazarus/1.4RC1/components/lazutils/lib/x86_64-linux/fileutil.ppu, пакет LazUtils
Запускаю другой лазарь (1.0.1), который я установил из реп. Точно такая же ошибка за исключением каталога Лазаря (что логично).
При попытке запуска скомпиленного бинарника - ошибка (что-то про семафоры).
Поиск в Инете ничего не говорит. Вообще.
Прошу помощи. Заранее благодарен.

ЗЫ: столько лет прошло, а проблемы с установкой Лазаря никуда не делись. Да...

Добавлено спустя 26 минут 56 секунд:
Твою дивизию ...
По кнопке F9 все запускается, и созданный таким образом бинарник тоже...
RustemNur
новенький
 
Сообщения: 61
Зарегистрирован: 20.02.2011 11:21:14
Откуда: Уфа

Re: После установки Лазаря на первом запуске "несовместимый

Сообщение Helltar » 19.02.2015 23:50:05

Во время установки был предупрежден, что пакет lazarus не установился, т.к. остались неразрешенные зависимости (fpc установились без вопросов).
Чтобы долго не париться, установил lazarus 1.0.1, который есть в официальных репах, затем без проблем поставился лазарь 1.4

Код: Выделить всё
sudo apt-get -f install


ЗЫ: столько лет прошло, а проблемы с установкой Лазаря никуда не делись. Да...

Нет никаких проблем с установкой.
Аватара пользователя
Helltar
новенький
 
Сообщения: 22
Зарегистрирован: 11.07.2013 02:28:53

Re: После установки Лазаря на первом запуске "несовместимый

Сообщение slyubez » 19.01.2018 23:46:51

Апну-ка я эту тему. Столкнувшись с этой проблемой, я был в некотором тупике. Но на простом проекте кое-что стало ясно.
Пользую Mint 17.3. Сделал свежую установку Lazarus 1.8.0. Открыл простой проект из одной формы, созданный на другом компе в 1.6.2, и наткнулся на эту заразу. Я изначально полагал, что что-то не то происходит именно при компиляции. Перетащил проект на винт с флэшки в домашний каталог, открываю проект из этого каталога, запускаю - то же самое. Вытер папку lib из каталога проекта на винте. Запускаю - бесполезно. Присматриваюсь внимательнее к логам компиляции - оказывается, эта сволочь компилирует проект на флэшку, а не на винт. Где и как настроить, пока не пойму. Надо ковыряться дальше.
slyubez
постоялец
 
Сообщения: 130
Зарегистрирован: 31.03.2015 08:44:07

Re: После установки Лазаря на первом запуске "несовместимый

Сообщение zoltanleo » 28.02.2018 23:31:18

slyubez писал(а): Где и как настроить, пока не пойму. Надо ковыряться дальше.


Project Options --> Compiler option --> Paths
смотришь Unit output directory(-Fu) по умолчанию lib\$(TargetCPU)-$(TargetOS)
и Include files (-Fi) по умолчанию $(ProjOutDir)
Аватара пользователя
zoltanleo
постоялец
 
Сообщения: 230
Зарегистрирован: 17.10.2013 10:55:01


Вернуться в Общее

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5

Рейтинг@Mail.ru